Core HR app is experiencing degraded service.

Incident Report for Lucca

Resolved

Lucca applications are now fully available.

Les applications Lucca sont maintenant totalement disponibles.
Posted Apr 10, 2025 - 17:25 UTC

Investigating

Core HR app is experiencing degraded service. We are working to resolve this as quickly as possible.
Posted Apr 10, 2025 - 16:36 UTC